DeleteFitPoint Method (ActiveX)

Deletes the fit point of a spline at a given index.

Supported platforms: Windows only

Signature

VBA:

object.DeleteFitPoint Index
object

Type: Spline

The object this method applies to.

Index

Access: Input-only

Type: Integer

An index position in the fit point list. Positive integers between 0 and N-1, where N is the total number of fit points for the spline.

Return Value (RetVal)

No return value.

Remarks

AutoCAD removes the fit point and refits the spline through the remaining points. There must be at least three fit points in the spline for this method to succeed. To view the changes, use the Update or Regen method.

Examples

VBA:

Sub Example_DeleteFitPoint()
    ' This example creates a spline object in model space.
    ' It then deletes a fit point from the spline.

    ' Create the spline
    Dim splineObj As AcadSpline
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    Dim fitPoints(0 To 8) As Double
    
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0
    fitPoints(0) = 1: fitPoints(1) = 1: fitPoints(2) = 0
    fitPoints(3) = 5: fitPoints(4) = 5: fitPoints(5) = 0
    fitPoints(6) = 10: fitPoints(7) = 0: fitPoints(8) = 0
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(fitPoints, startTan, endTan)
    ZoomAll
    MsgBox "Delete the first fit point", , "DeleteFitPoint Example"
    
    ' Delete the first fit point in the spline
    splineObj.DeleteFitPoint 0
    ThisDrawing.Regen True
    MsgBox "A fit point has been deleted at Index: 0", , "DeleteFitPoint Example"

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DeleteFitPoint()
    ;; This example creates a spline object in model space.
    ;; It then deletes a fit point from the spline.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Create the spline
    (setq startTan (vlax-3d-point 0.5 0.5 0)
          endTan (vlax-3d-point 0.5 0.5 0)
          fitPoints (vlax-make-safearray vlax-vbDouble '(0 . 8)))
    (vlax-safearray-fill fitPoints '(1 1 0
				                                 5 5 0
				                                 10 0 0
				                                )
    )

    (setq modelSpace (vla-get-ModelSpace doc))
    (setq splineObj (vla-AddSpline modelSpace fitPoints startTan endTan))
    (vla-ZoomAll acadObj)
    (alert "Delete the first fit point.")
    
    ;; Delete the first fit point in the spline
    (vla-DeleteFitPoint splineObj 0)
    (vla-Regen doc :vlax-true)
    (alert "A fit point has been deleted at Index: 0")
)