Triggered after the user right-clicks on the drawing window, and before the shortcut menu appears in command mode.
Supported platforms: Windows only
VBA:
object.BeginShortcutMenuCommand(ShortcutMenu, Command)
Type: Document
An object expression that evaluates to a valid container object. In this case, the only valid container is a document.
Type: PopupMenu object; input/output from the handler
The shortcut menu about to be displayed.
Type: String; input to the handler only
The name of the command in process.
This event allows you to make changes to the shortcut menu before it is displayed. To make changes to the shortcut menu, edit the PopupMenu object that is passed in to your handler from the event. This same PopupMenu object is passed out of the handler as the current shortcut menu. Use the EndShortcutMenu event to perform any cleanup work on the shortcut menu.
There is a command in progress when this event is triggered.
This event is triggered after all shortcut menu elements, including any ObjectARX command additions, have occurred.
No events will be fired while a modal dialog is being displayed.
VBA:
Private Sub AcadDocument_BeginShortcutMenuCommand(ShortcutMenu As AutoCAD.IAcadPopupMenu, ByVal Command As String) ' This example intercepts a shortcut menu start while you are in the command mode. ' MsgBox "You have just initiated a shortcut menu in command mode!" End Sub
Visual LISP:
Not available