UseStandardScale Property (ActiveX)

Specifies if the plot is to use a standard or custom scale.

Supported platforms: Windows only

Signature

VBA:

object.UseStandardScale
object

Type: Layout, PlotConfiguration

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

To specify the standard scale to use in the plot, use the StandardScale property. To specify a custom scale, use the SetCustomScale method.

Examples

VBA:

Sub Example_UseStandardScale()
    ' This example will access the Layouts collection for the current drawing
    ' and list the status of UseStandardScale for each Layout.

    Dim Layouts As AcadLayouts, Layout As ACADLayout
    Dim msg As String
    
    ' Get layouts collection from document object
    Set Layouts = ThisDrawing.Layouts
    
    msg = ""
    
    ' Get the UseStandardScale information of every layout in this drawing
    For Each Layout In Layouts
        If Layout.UseStandardScale Then
            msg = msg & Layout.name & " uses the standard scale." & vbCrLf
        Else
            msg = msg & Layout.name & " uses a custom scale." & vbCrLf
        End If
    Next
    
    ' Display the information
    MsgBox msg
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_UseStandardScale()
    ;; This example will access the Layouts collection for the current drawing
    ;; and list the status of UseStandardScale for each Layout.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Get layouts collection from document object
    (setq Layouts (vla-get-Layouts doc)
          msg "")
    
    ;; Get the UseStandardScale information of every layout in this drawing
    (vlax-for Layout Layouts
        (if (= (vla-get-UseStandardScale Layout) :vlax-true)
            (setq msg (strcat msg (vla-get-Name Layout) " uses the standard scale.\n"))
            (setq msg (strcat msg (vla-get-Name Layout) " uses a custom scale.\n"))
        )
    )
    
    ;; Display the information
    (alert msg)
)