TextGap Property (ActiveX)

Specifies the distance between the dimension text and the dimension line when you break the dimension line to accommodate dimension text.

Supported platforms: Windows only

Signature

VBA:

object.TextGap
object

Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, Dimension, DimOrdinate, DimRadial, DimRadialLarge, DimRotated, Leader

The objects this property applies to.

Property Value

Read-only: No

Type: Double

A real number specifying the gap distance.

Remarks

This property also sets the gap between the annotation and a hook line on a Leader object.

A negative value creates basic dimensioning (dimension text with a box around the text).

Note: This property overrides the value of the DIMGAP system variable for the given dimension.

Examples

VBA:

Sub Example_TextGap()
   ' This example creates an aligned dimension in model space and
   ' uses the TextGap property to increase the distance between the
   ' dimension line and the dimension text

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    
    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 5.5: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ThisDrawing.Application.ZoomAll

    ' Read and display current dimension gap
    MsgBox "The dimension gap for this object is currently set to: " & dimObj.TextGap

    ' Increase the distance of the dimension gap
    dimObj.TextGap = 0.5
    ThisDrawing.Regen acAllViewports
    
    ' Read and display current dimension gap
    MsgBox "The dimension gap for this object is now set to: " & dimObj.TextGap
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_TextGap()
    ;; This example creates an aligned dimension in model space and
    ;; uses the TextGap property to increase the distance between the
    ;; dimension line and the dimension text
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 5 0)
          point2 (vlax-3d-point 5.5 5 0)
          location (vlax-3d-point 5 7 0))
    
    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    (vla-ZoomAll acadObj)

    ;; Read and display current dimension gap
    (alert (strcat "The dimension gap for this object is currently set to: " (rtos (vla-get-TextGap dimObj) 2)))

    ;; Increase the distance of the dimension gap
    (vla-put-TextGap dimObj 0.5)
    (vla-Regen doc acAllViewports)
    
    ;; Read and display current dimension gap
    (alert (strcat "The dimension gap for this object is now set to: " (rtos (vla-get-TextGap dimObj) 2)))
)