RoundDistance Property (ActiveX)

Specifies the rounding of dimension units.

Supported platforms: Windows only

Signature

VBA:

object.RoundDistance
object

Type: DimAligned, DimArcLength, DimDiametric, DimOrdinate, DimRadial, DimRadialLarge, DimRotated

The objects this property applies to.

Property Value

Read-only: No

Type: Double

A positive real number representing the value to round distances to. The initial value is 0.00.

Remarks

This property rounds all dimensioning distances to the specified value. For instance, if this property is set to 0.25, the distance is rounded to the nearest 0.25 unit. If you set this property to 1.0, the distance for the dimension is rounded to the nearest integer. Note that the number of digits edited after the decimal point depends on the precision set by the PrimaryUnitsPrecision property or DIMDEC system variable. This property does not apply to angular dimensions.

Note: This property overrides the value of the DIMRND system variable for the given dimension.

Examples

VBA:

Sub Example_RoundDistance()
    ' This example creates an aligned dimension in model space and
    ' uses RoundDistance to set the unit display
    ' of the dimension to rounded values

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    
    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 10.123: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    
    ThisDrawing.Application.ZoomAll
    
    MsgBox "Press any key to round the dimension unit display to .5"
    
    ' Round the distance of the dimension to 0.50 of a unit
    dimObj.RoundDistance = 0.5
    ThisDrawing.Regen acAllViewports
    
    MsgBox "Dimension units have been rounded to: " & dimObj.RoundDistance

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_RoundDistance()
    ;; This example creates an aligned dimension in model space and
    ;; uses RoundDistance to set the unit display
    ;; of the dimension to rounded values
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 5 0)
          point2 (vlax-3d-point 10.123 5 0)
          location (vlax-3d-point 5 7 0))
    
    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))

    (vla-ZoomAll acadObj)
    
    (alert "Dimensions value will now be rounded to the nearest 0.50 of a unit")
    
    ;; Round the distance of the dimension to 0.50 of a unit
    (vla-put-RoundDistance dimObj 0.5)
    (vla-Regen doc acAllViewports)
    
    (alert (strcat "Dimension units have been rounded to: " (rtos (vla-get-RoundDistance dimObj) 2)))
)