Determines whether the given spline is rational.
Supported platforms: Windows only
Read-only: Yes
Type: Boolean
No additional remarks.
VBA:
Sub Example_IsRational() ' This example creates a spline object in model space. ' It then determines whether the spline is rational or non-rational ' based on the IsRational property. ' Create the spline Dim splineObj As AcadSpline Dim startTan(0 To 2) As Double Dim endTan(0 To 2) As Double Dim fitPoints(0 To 8) As Double startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0 endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0 fitPoints(0) = 1: fitPoints(1) = 1: fitPoints(2) = 0 fitPoints(3) = 5: fitPoints(4) = 5: fitPoints(5) = 0 fitPoints(6) = 10: fitPoints(7) = 0: fitPoints(8) = 0 Set splineObj = ThisDrawing.ModelSpace.AddSpline(fitPoints, startTan, endTan) ZoomAll ' Display a message according to the IsRational value for the spline. If splineObj.IsRational Then MsgBox "The newly created Spline is a rational Spline", , "IsRational Example" Else MsgBox "The newly created Spline is a non-rational Spline", , "IsRational Example" End If End Sub
Visual LISP:
(vl-load-com) (defun c:Example_IsRational() ;; This example creates a Spline object in model space and ;; determines whether the Spline is planar (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the Spline object (setq startTan (vlax-3d-point 0.5 0.5 0) endTan (vlax-3d-point 0.5 0.5 0) fitPoints (vlax-make-safearray vlax-vbDouble '(0 . 8))) (vlax-safearray-fill fitPoints '(0 0 0 5 5 0 10 0 0 ) ) ;; Create new Spline object (setq modelSpace (vla-get-ModelSpace doc)) (setq splineObj (vla-AddSpline modelSpace fitPoints startTan endTan)) (vla-ZoomAll acadObj) ;; Display a message according to the IsRational value for the spline. (if (= (vla-get-IsRational splineObj) :vlax-true) (alert "The newly created Spline is a rational Spline") (alert "The newly created Spline is a non-rational Spline") ) )