IAcadEntity Interface (ActiveX)

The standard interface for a basic AutoCAD entity.

Supported Platforms: Windows only

Class Information

Class Name

AcadEntity

Object Inheritance
Object
   AcadObject
      AcadEntity
Create Using

VBA

ModelSpace.Add<object>
PaperSpace.Add<object>
Block.Add<object>
ModelSpace.AttachExternalReference
PaperSpace.AttachExternalReference
Block.AttachExternalReference
ModelSpace.InsertBlock
PaperSpace.InsertBlock
Block.InsertBlock
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Remarks

IAcadEntity interface represents the default interface for AutoCAD entities.

If you are familiar with the ObjectARX environment you will see that IAcadEntity exposes AcDbEntity functionality.