ToleranceHeightScale Property (ActiveX)

Specifies a scale factor for the text height of tolerance values relative to the dimension text height.

Supported platforms: Windows only

Signature

VBA:

object.ToleranceHeightScale
object

Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, Dimension, DimOrdinate, DimRadial, DimRadialLarge, DimRotated

The object this property applies to.

Property Value

Read-only: No

Type: Double

The scale factor for the tolerance values.

Remarks

The initial value for this property is 1.0000.

This property is only available when the ToleranceDisplay property is set to any value other than acTolNone.

Use this property for plus and minus tolerance strings when DIMTOL is on and DIMTM is not equal to DIMTP, or when DIMLIM is on.

Note: This property overrides the value of the DIMTFAC system variable for the given dimension.

Examples

VBA:

Sub Example_ToleranceHeightScale()
    ' This example creates an aligned dimension in model space and
    ' turns on the tolerance display for the new dimension.  The height
    ' of the tolerance text can then be adjusted by the user

    Dim dimObj As AcadDimAligned
    Dim newText As AcadTextStyle
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    Dim CurrentScale As Integer
    
    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 5.5: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    
    ' Turn on the tolerance display
    dimObj.ToleranceDisplay = acTolSymmetrical
    
    ThisDrawing.Application.ZoomAll
    
Increase:
    ' Read and display the current tolerance height scale for this dimension
    If MsgBox("The tolerance height scale is currently set to: " & dimObj.ToleranceHeightScale & vbCrLf & _
              "Press OK to increase, or cancel to finish", vbOKCancel) = vbCancel Then
        
        Exit Sub
    End If
    
    ' Increase the tolerance height scale for this dimension
    dimObj.ToleranceHeightScale = dimObj.ToleranceHeightScale + 1
    
    ThisDrawing.Regen acAllViewports
    
    GoTo Increase
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ToleranceHeightScale()
    ;; This example creates an aligned dimension in model space and
    ;; turns on the tolerance display for the new dimension.  The height
    ;; of the tolerance text can then be adjusted by the user
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 5 0)
          point2 (vlax-3d-point 5.5 5 0)
          location (vlax-3d-point 5 7 0))
    
    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    
    ;; Turn on the tolerance display
    (vla-put-ToleranceDisplay dimObj acTolSymmetrical)
    
    (vla-ZoomAll acadObj)
    (vla-Regen doc acAllViewports)
    
    ;; Read and display the current tolerance height scale for this dimension
    (alert (strcat "The tolerance height scale is currently set to: " (rtos (vla-get-ToleranceHeightScale dimObj) 2)))
    
    ;; Increase the tolerance height scale for this dimension
    (vla-put-ToleranceHeightScale dimObj (1+ (vla-get-ToleranceHeightScale dimObj)))
    
    (vla-Regen doc acAllViewports)
    
    ;; Read and display the current tolerance height scale for this dimension
    (alert (strcat "The tolerance height scale is now set to: " (rtos (vla-get-ToleranceHeightScale dimObj) 2)))
)