vl-doc-ref (AutoLISP)

Retrieves the value of a variable from the current document's namespace

Supported Platforms: Windows and Mac OS

Signature

(vl-doc-ref 'symbol)
'symbol

Type: Symbol

A symbol naming a variable.

Return Values

Type: Integer, Real, String, List, ads_name, T, or nil

The value of the variable identified by symbol.

Remarks

This function can be used by a separate-namespace application to retrieve the value of a variable from the current document's namespace.

Examples

(vl-doc-ref 'foobar)
"Rinky dinky stinky"