vl-bb-ref (AutoLISP)

Returns the value of a variable from the blackboard namespace

Supported Platforms: Windows and Mac OS

Signature

(vl-bb-ref 'variable)
'variable

Type: Symbol

A symbol identifying the variable to be retrieved.

Return Values

Type: Integer, Real, String, List, ads_name, T, or nil

The value of the variable named by symbol.

Examples

Set a variable in the blackboard:

(vl-bb-set 'foobar "Root toot toot")
"Root toot toot"

Use vl-bb-ref to retrieve the value of foobar from the blackboard:

(vl-bb-ref 'foobar)
"Root toot toot"