vlr-owner-add (AutoLISP/ActiveX)

Adds an object to the list of owners of an object reactor

Supported Platforms: Windows only

Signature

(vlr-owner-add reactor owner)
reactor

Type: VLR object

An object.

owner

Type: VLA-object

An object to be added to the list of notifiers for this reactor.

Return Values

Type: VLA-object

The object to which the reactor has been added.

Remarks

This function adds a new source of reactor events; the reactor will receive events from the specified object.

Examples

In the following example, an arc object named “archie” is added to the owner list of reactor circleReactor:

(vlr-owner-add circleReactor archie)
#<VLA-OBJECT IAcadArc 03ad0bcc>