vlr-reaction-name (AutoLISP/ActiveX)

Returns a list of all possible callback conditions for this reactor type

Supported Platforms: Windows only

Signature

(vlr-reaction-names reactor-type)
reactor-type

Type: Symbol

One of the following:

  • :VLR-AcDb-Reactor

  • :VLR-Command-Reactor

  • :VLR-DeepClone-Reactor

  • :VLR-DocManager-Reactor

  • :VLR-DWG-Reactor

  • :VLR-DXF-Reactor

  • :VLR-Editor-Reactor

  • :VLR-Insert-Reactor

  • :VLR-Linker-Reactor

  • :VLR-Lisp-Reactor

  • :VLR-Miscellaneous-Reactor

  • :VLR-Mouse-Reactor

  • :VLR-Object-Reactor

  • :VLR-SysVar-Reactor

  • :VLR-Toolbar-Reactor

  • :VLR-Undo-Reactor

  • :VLR-Wblock-Reactor

  • :VLR-Window-Reactor

  • :VLR-XREF-Reactor

Return Values

Type: List

A list of symbols indicating the possible events for the specified reactor type.

Examples

(vlr-reaction-names :VLR-Editor-Reactor)
(:vlr-unknownCommand :vlr-commandWillStart :vlr-commandEnded....