layerstate-getnames (AutoLISP)

Returns a list of the layer state names

Supported Platforms: Windows and Mac OS

Signature

(layerstate-getnames [includehidden] [includexref])
includehidden

Type: T or nil

If includehidden is T, the list will include the names of hidden layer states. If omitted or nil, hidden layer states will be excluded.

includexref

Type: T or nil

If includexref is nil, the list will exclude the names of xref layer states. If omitted or T, xref layer states will be included

Return Values

Type: List or nil

Returns a list of the layer state names.

Examples

(layerstate-getnames)
("First Floor" "Second Floor" "Foundation")