The following table provides summary descriptions of the AutoLISP application-handling functions.
Application-handling functions |
|
---|---|
Function |
Description |
(arx) |
Returns a list of the currently loaded ObjectARX applications |
(arxload application [onfailure]) |
Loads an ObjectARX application |
(arxunload application [onfailure]) |
Unloads an ObjectARX application |
(autoarxload filename cmdlist) |
Predefines command names to load an associated ObjectARX file |
(autoload filename cmdlist) |
Predefines command names to load an associated AutoLISP file |
(initdia [dialogflag]) |
Forces the display of the next command's dialog box |
(load filename [onfailure]) |
Evaluates the AutoLISP expressions in a file |
(showhtmlmodalwindow uri) |
Displays a modal dialog box with a specified URI (Uniform Resource Identifier) |
(startapp appcmd file) |
Starts a Windows application |
(vl-load-all filename) |
Loads a file into all open AutoCAD documents |
(vl-vbaload "filename") |
Loads a VBA project |
(vl-vbarun "macroname") |
Runs a VBA macro |
(vlax-add-cmd "global-name" 'func-sym [“local-name" cmd-flags]) |
Adds commands to the AutoCAD built-in command set Note: Extended AutoLISP extension: requires vl-load-com
|