vl-string-trim (AutoLISP)

Removes the specified characters from the beginning and end of a string

Supported Platforms: Windows and Mac OS

Signature

(vl-string-trim char-set str)
char-set

Type: String

Characters to be removed.

str

Type: String

The textual value to be trimmed of char-set.

Return Values

Type: String

The value of str, after any characters have been trimmed.

Examples

(vl-string-trim " \t\n" " \t\n STR \n\t ")
"STR"

(vl-string-trim "this is junk" "this is junk Don't call this junk! this is junk")
"Don't call this junk!"

(vl-string-trim " " "      Leave me alone   ")
"Leave me alone"