GetObjectAliases Method (ActiveX/CSP)

Returns the alias names stored for an AutoCAD object.

For internal use only.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

object.GetObjectAliases(pObj, szName, pAliasArray)

C#:

object.GetObjectAliases(pObj, szName, ref pAliasArray);
object

Type: AcStManager object

The object this method applies to.

pObj

Access: Input-only

Type: AcadObject object

The object for which aliases are requested.

szName

Access: Input-only

Type: String

The name of the alias to retrieve.

pAliasArray

Access: Input/Output

Type: Variant (Array of Strings)

The names of the plug-ins associated with the alias.

Return Value (RetVal)

No return value.

Remarks

Aliases are defined by plug-ins in one or more tables; each table is identified by a name.

The meaning of an alias is not defined by the Standards framework. This function allows plug-ins and host applications to store and retrieve information about objects.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Not available

C#:

Not available