SetObjectAliases Method (ActiveX/CSP)

Sets the aliases for a database object.

For internal use only.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

object.SetObjectAliases(pObj, szName, aliasArray)

C#:

object.SetObjectAliases(pObj, szName, aliasArray);
object

Type: AcStManager object

The object this method applies to.

pObj

Access: Input-only

Type: AcadObject object

The object for which aliases are to be set.

szName

Access: Input-only

Type: String

The name of the alias to set.

aliasArray

Access: Input-only

Type: Variant (Array of Strings)

The names of the plug-ins to associate with the alias.

Return Value (RetVal)

No return value.

Remarks

Aliases defined by plug-ins are stored in one or more tables. Each table is identified by the string passed in szName.

The meaning of an alias table is not defined by the Standards framework. This method allows plug-ins and the host application to store and retrieve information on database objects.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Not available

C#:

Not available