SubscribeSheetSetNotification Method (ActiveX/ATO)

Registers a sheet set notification handler for the transmittal set.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

VB.NET:

object.subscribeSheetSetNotification(pHandler)

C#:

object.subscribeSheetSetNotification(pHandler);
object

Type: TransmittalOperation object

The object this method applies to.

pHandler

Access: Input-only

Type: ITransmittalSheetSetNotification interface

The sheet set notification handler to register.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2005 and later

Examples

VB.NET:

' Notification handlers
Private Shared g_dbHandler As New MyTransDbNotifier
Private Shared g_fileHandler As New MyTransFileNotifier
Private Shared g_ssmHandler As New MyTransSSMNotifier

' Custom command that subscribes to eTransmit notifications
' Works with the transmittal API and ETRANSMIT/ARCHIVE commands
<CommandMethod("ETNotificationsStart")> _
Public Shared Sub ETNotificationsStart()
    ' Add the handlers
    g_tro.subscribeToAddFileNotification(g_fileHandler)
    g_tro.subscribeDatabaseNotification(g_dbHandler)
    g_tro.subscribeSheetSetNotification(g_ssmHandler)
End Sub

' Custom command that unsubscribes to eTransmit notifications
' Works with the transmittal API and ETRANSMIT/ARCHIVE commands
<CommandMethod("ETNotificationsEnd")> _
Public Shared Sub ETNotificationsEnd()
    ' Remove the handlers
    g_tro.cancelSubscriptionToAddFileNotification(g_fileHandler)
    g_tro.cancelDatabaseNotification(g_dbHandler)
    g_tro.cancelSheetSetNotification(g_ssmHandler)
End Sub

C#:

// Notification handlers
private static MyTransDbNotifier g_dbHandler = new MyTransDbNotifier();
private static MyTransFileNotifier g_fileHandler = new MyTransFileNotifier();
private static MyTransSSMNotifier g_ssmHandler = new MyTransSSMNotifier();

// Custom command that subscribes to eTransmit notifications
// Works with the transmittal API and ETRANSMIT/ARCHIVE commands
[CommandMethod("ETNotificationsStart")]
public static void ETNotificationsStart()
{
    // Add the handlers
    g_tro.subscribeToAddFileNotification(g_fileHandler);
    g_tro.subscribeDatabaseNotification(g_dbHandler);
    g_tro.subscribeSheetSetNotification(g_ssmHandler);
}

// Custom command that unsubscribes to eTransmit notifications
// Works with the transmittal API and ETRANSMIT/ARCHIVE commands
[CommandMethod("ETNotificationsEnd")]
public static void ETNotificationsEnd()
{
    // Remove the handlers
    g_tro.cancelSubscriptionToAddFileNotification(g_fileHandler);
    g_tro.cancelDatabaseNotification(g_dbHandler);
    g_tro.cancelSheetSetNotification(g_ssmHandler);
}