CheckSysvar Method (ActiveX/CSP)

Checks a system variable for an incorrect value.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature - AcStErrorIterator object

For internal use only.

VB.NET:

RetVal = object.CheckSysvar(sysVarName, bGetAllFixes)

C#:

RetVal = object.CheckSysvar(sysVarName, ref bGetAllFixes);
object

Type: AcStErrorIterator object

The object this method applies to.

sysVarName

Access: Input-only

Type: String

The name of the system variable to check.

bGetAllFixes

Access: Input-only

Type: Boolean

  • False: Only a description of the error is obtained.
  • True: All possible fixes that can be applied are obtained.

Signature - IAcStPlugin2 interface

VB.NET:

Public Function CheckSysvar(sysVarName, bGetAllFixes) As Boolean _
                Implements AcStMgr.IAcStPlugin2.CheckSysvar 
    Return ...
End Function

C#:

public bool Done(sysVarName, bGetAllFixes)
{
    return ...;
}
object

Type: IAcStPlugin2 object

The object this method applies to.

sysVarName

Access: Input-only

Type: String

The name of the system variable to check.

bGetAllFixes

Access: Input-only

Type: Boolean

  • False: Only a description of the error is obtained.
  • True: All possible fixes that can be applied are obtained.
bPassFail

Access: Output-only

Type: Boolean

  • False: An error was encountered.
  • True: No error was encountered.

Return Value (RetVal)

Type: Boolean

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2004 and later

Examples - AcStErrorIterator object

VB.NET:

Not available

C#:

Not available

Examples - IAcStPlugin2 interface

VB.NET:

Public Sub CheckSysvar(ByVal syvarName As String, _
                       ByVal bGetAllFixes As Boolean, _
                       ByRef bPassFail As Boolean) _
                       Implements IAcStPlugin2.CheckSysvar

    ' Not implemented
End Sub

C#:

public void CheckSysvar(string syvarName, bool bGetAllFixes, ref bool bPassFail)
{
    // Not implemented
}