Interface that allows a plug-in to participate in the drawing standards checking process.
Supported platforms: Windows only
Namespace: AcStMgr
Assembly: AcStMgr.tlb
IAcStPlugin2
Object IAcStPlugin2
VB.NET
Public Class <custom_class_name> Implements AcStMgr.IAcStPlugin2 ... End Class
C#
internal class <custom_class_name> : AcStMgr.IAcStPlugin2 { ... }
VB.NET
User-defined variable
C#
User-defined variable
These members are part of this object:
The IAcStPlugin2 interface must be implemented by a plug-in that wants to participate in the checking of a drawing managed by an AcStErrorIterator object. The plug-in checks a drawing for errors against a set of standards defined and implemented by the plug-in, and reports errors by creating an AcStError object that is passed to the plug-in by the Standards Framework. Optionally, the plug-in can implement code for fixing errors by creating a AcStFix object. The plug-in also implements methods to provide information such as the version and author of the plug-in.
All plug-ins must contain definitions for specific properties and methods, while other properties and methods are option based on if the plug-in supports the CAD Standards feature in the AutoCAD program and/or Batch Standards Checker. The following table outlines when and which properties and methods must be defined as part of a custom class that implements/inherits from the IAcStPlugin2 interface.
Method/Property Name | CAD Standards | Batch Standards Checker |
---|---|---|
Methods | ||
CheckSysvar | Required | Optional |
Clear | Required | Optional |
Done | Required | Optional |
FixError | Required | Optional |
GetAllFixes | Required | Optional |
GetError | Required | Required |
GetObjectFilter | Required | Required |
GetPropertyDiffs | Required | Optional |
GetRecommendedFix | Optional | Optional |
Initialize | Required | Required |
Next | Required | Optional |
SetContext | Required | Optional |
SetupForAudit | Required | Required |
StampDatabase | Required | Optional |
Start | Required | Optional |
UpdateStatus | Required | Required |
WritePluginInfo | Optional | Optional |
Properties | ||
Author | Required | Required |
Description | Required | Required |
HRef | Required | Required |
Icon | Required | Required |
Name | Required | Required |
Version | Required | Required |
Releases: AutoCAD 2004 and later