SetObjectFlags Method (ActiveX/CSP)

Sets the standards flags for an object in the database.

For internal use only.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

object.SetObjectFlags(pObj, flags, szUserIgnore, szAppIgnore)

C#:

object.SetObjectFlags(pObj, flags, szUserIgnore, szAppIgnore);
object

Type: AcStManager object

The object this method applies to.

pObj

Access: Input-only

Type: AcadObject object

The object whose flags to set.

flags

Access: Input-only

Type: AcStFlags enum

The bitwise value of the flags to set for the object.

szUserIgnore

Access: Input-only

Type: String

The name of the user who is ignoring the error.

szAppIgnore

Access: Input-only

Type: String

The name of the application that is ignoring the error.

Return Value (RetVal)

No return value.

Remarks

The flags are used to identify objects that have been marked ignored by an application or a user.

The flags can be one or more values from the AcStFlags enumeration.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Not available

C#:

Not available