Start Method (ActiveX/CSP)

Initializes the checking of an error.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature - AcStErrorIterator object

For internal use only.

VB.NET:

object.Start([bShowIgnored])

C#:

object.Start([bShowIgnored]);
object

Type: AcStErrorIterator object

The object this method applies to.

bShowIgnored

Access: Input-only

Type: Boolean

If the error was marked as ignored,

  • False: Do not allow the checking of the error
  • True: Allow the checking of the error

Signature - IAcStPlugin2 interface

VB.NET:

Public Sub Start(pStartError) _
                    Implements IAcStPlugin2.Start
    ...
End Sub

C#:

public void Start(pStartError)
{
    ...;
}
object

Type: IAcStPlugin2 interface

The interface this method applies to.

pStartError

Access: Input-only

Type: AcStError object

The error object to check.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Public Sub PlugIn_Start(ByVal pStartError As AcStError) _
                        Implements IAcStPlugin2.Start

    ' pStartError is not an actual programming error that needs to be handled,
    ' but a reference to an object that does not match the standards
    ' in the DWS file.

    ' If pStartError is an object, checking should start
    ' from that error, not the beginning of the current context.
    If IsNothing(pStartError) = False Then

        ' Get the ObjectId of the first object to check
        Dim badId As Long = pStartError.BadObjectId

        ' Find the index for ObjectId in the context list stored in m_objIDArray
        For m_curIndex = 0 To m_ContextList.Count - 1
            If m_ContextList.Item(m_curIndex) = badId Then
                m_curIndex = m_curIndex - 1
                PlugIn_Next()
            End If
        Next
    Else
        ' A valid AcStError object was not passed to the method.
        ' Checking should start at the beginning of the context list.
        m_curIndex = -1
        PlugIn_Next()
    End If
End Sub

C#:

public void PlugIn_Start(AcStError pStartError)
{
    // pStartError is not an actual programming error that needs to be handled,
    // but a reference to an object that does not match the standards
    // in the DWS file.

    // If pStartError is an object, checking should start
    // from that error, not the beginning of the current context.
    if ((pStartError == null) == false)
    {
        // Get the ObjectId of the first object to check
        long badId = pStartError.BadObjectId;

        // Find the index for ObjectId in the context list stored in m_objIDArray
        for (m_curIndex = 0; m_curIndex <= m_ContextList.Count - 1; m_curIndex++)
        {
            if (Convert.ToInt64(m_ContextList.GetItem(m_curIndex)) == badId)
            {
                m_curIndex = m_curIndex - 1;
                PlugIn_Next();
            }
        }
    }
    else
    {
        // A valid AcStError object was not passed to the method.
        // Checking should start at the beginning of the context list.
        m_curIndex = -1;
        PlugIn_Next();
    }
}

void IAcStPlugin2.Start(AcStError pStartError)
{
    PlugIn_Start(pStartError);
}