StampDatabase Method (ActiveX/CSP)

Reports whether the plug-in uses the database to check the drawing.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature - AcStManager object

For internal use only.

VB.NET:

object.StampDatabase(pDb, pluginProgIdArray)

C#:

object.StampDatabase(pDb, pluginProgIdArray);
object

Type: AcStManager object

The object this method applies to.

pDb

Access: Input-only

Type: AcadDatabase object

The database object to check.

pluginProgIdArray

Access: Input-only

Type: Variant (Array of Strings)

The database object to check.

Signature - IAcStPlugin2 interface

VB.NET:

Public Sub StampDatabase(pDb, pStampIt) _
                    Implements IAcStPlugin2.StampDatabase
    ...
End Sub

C#:

public void StampDatabase(pDb, ref pStampIt)
{
    ...;
}
object

Type: IAcStPlugin2 interface

The interface this method applies to.

pDb

Access: Input-only

Type: AcadDatabase object

The database object to check.

pStampIt

Access: Input/Output

Type: Boolean

  • False: Objects in the database were not checked; objects in an object ID list were checked
  • True: Objects in the database were checked

Return Value (RetVal)

No return value.

Remarks

This method stamps the database object with information about a plug-in, such as the name and version. The information is used to determine which plug-ins a DWS file needs to support it.

The StampDatabase method of the AcStManager object instantiates each plug-in identified in pluginProgIdArray and calls the plug-in's StampDatabase method of the IAcStPlugin interface. If the pStampIt value returned is True, this method embeds information about the plug-in.

Release Information

Releases: AutoCAD 2004 and later

Examples - AcStManager object

VB.NET:

Not available

C#:

Not available

Examples - IAcStPlugin2 interface

VB.NET:

Public Sub StampDatabase(ByVal pDb As AcadDatabase, _
                         ByRef pStampIt As Boolean) _
                         Implements IAcStPlugin2.StampDatabase

    ' << Change based on standards implementation >>
    ' If the DWS contains layers, return true
    ' Otherwise, return false
    pStampIt = False

    If pDb.Layers.Count > 0 Then
        pStampIt = True
    End If
End Sub

C#:

public void StampDatabase(AcadDatabase pDb, ref bool pStampIt)
{
    // << Change based on standards implementation >>
    // If the DWS contains layers, return true
    // Otherwise, return false
    pStampIt = false;
    if (pDb.Layers.Count > 0)
    {
        pStampIt = true;
    }
}