Unregisters a database callback notification handler that was previously registered.
Namespace: TRANSMITTALLib
Assembly: AcETransmit19.tlb
VB.NET:
object.cancelDatabaseNotification pHandler
C#:
object.cancelDatabaseNotification(pHandler);
Type: TransmittalOperation object
The object this method applies to.
Access: Input-only
Type: TransmittalDatabaseNotificationHandler object
The object that represents the custom class which implements the database notifications for your application.
No return value.
No additional remarks.
Releases: AutoCAD 2005 and later
VB.NET:
' Notification handlers Private Shared g_dbHandler As New MyTransDbNotifier Private Shared g_fileHandler As New MyTransFileNotifier Private Shared g_ssmHandler As New MyTransSSMNotifier ' Custom command that subscribes to eTransmit notifications ' Works with the transmittal API and ETRANSMIT/ARCHIVE commands <CommandMethod("ETNotificationsStart")> _ Public Shared Sub ETNotificationsStart() ' Add the handlers g_tro.subscribeToAddFileNotification(g_fileHandler) g_tro.subscribeDatabaseNotification(g_dbHandler) g_tro.subscribeSheetSetNotification(g_ssmHandler) End Sub ' Custom command that unsubscribes to eTransmit notifications ' Works with the transmittal API and ETRANSMIT/ARCHIVE commands <CommandMethod("ETNotificationsEnd")> _ Public Shared Sub ETNotificationsEnd() ' Remove the handlers g_tro.cancelSubscriptionToAddFileNotification(g_fileHandler) g_tro.cancelDatabaseNotification(g_dbHandler) g_tro.cancelSheetSetNotification(g_ssmHandler) End Sub
C#:
// Notification handlers private static MyTransDbNotifier g_dbHandler = new MyTransDbNotifier(); private static MyTransFileNotifier g_fileHandler = new MyTransFileNotifier(); private static MyTransSSMNotifier g_ssmHandler = new MyTransSSMNotifier(); // Custom command that subscribes to eTransmit notifications // Works with the transmittal API and ETRANSMIT/ARCHIVE commands [CommandMethod("ETNotificationsStart")] public static void ETNotificationsStart() { // Add the handlers g_tro.subscribeToAddFileNotification(g_fileHandler); g_tro.subscribeDatabaseNotification(g_dbHandler); g_tro.subscribeSheetSetNotification(g_ssmHandler); } // Custom command that unsubscribes to eTransmit notifications // Works with the transmittal API and ETRANSMIT/ARCHIVE commands [CommandMethod("ETNotificationsEnd")] public static void ETNotificationsEnd() { // Remove the handlers g_tro.cancelSubscriptionToAddFileNotification(g_fileHandler); g_tro.cancelDatabaseNotification(g_dbHandler); g_tro.cancelSheetSetNotification(g_ssmHandler); }