TransmittalDatabaseNotificationHandler Object (ActiveX/ATO)

Notification handler used to monitor the conversion and processing of a database of a drawing file in the transmittal set.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Class Information

Class Name

TransmittalDatabaseNotificationHandler

Object Inheritance
Object
   TransmittalDatabaseNotificationHandler
Create Using

VB.NET

Friend Class <custom_class_name>
    Implements TransmittalDatabaseNotificationHandler
    ...
End Class

C#

internal class <custom_class_name> : TransmittalDatabaseNotificationHandler
{
  ...
}
Access Via

VB.NET

User-defined variable; New <custom_class_name>

C#

User-defined variable; new <custom_class_name>

Members

These members are part of this object:

Methods

Properties

Events

convertDatabase

postDatabaseProcessing

preDatabaseProcessing

None

None

Remarks

The TransmittalDatabaseNotificationHandler interface is used to get notifications before and after the processing, and the conversion of a drawing.

Release Information

Releases: AutoCAD 2005 and later