Icon Property (ActiveX/CSP)

Returns the pointer to the icon assigned to the plug-in.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

Public ReadOnly Property Icon() As Long _
                Implements IAcStPlugin2.Icon
    Get
        Dim ico As New System.Drawing.Icon("...")
        Return ico
    End Get
End Property

C#:

public long Icon {
    get {
         Icon ico = new System.Drawing.Icon("...");
         return ico;
    }
}
object

Type: IAcStPlugin2 interface

The object this property applies to.

Property Value

Read-only: Yes

Type: LongPtr (Long)

The HICON for the plug-in's icon.

Plug-in icons must be 16x16 pixels in size. The icon is displayed in the CAD Standards dialog box and the Batch Standards Checker.

Implementation of this property is optional.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Public ReadOnly Property Icon() As Long _
                Implements IAcStPlugin2.Icon
    Get
        Return 1
    End Get
End Property

C#:

public long Icon
{
    get { return 1; }
}