GetError Method (ActiveX/CSP)

Returns the current error being checked.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature - AcStErrorIterator object

For internal use only.

VB.NET:

RetVal = object.GetError()

C#:

RetVal = object.GetError();
object

Type: AcStErrorIterator object

The object this method applies to.

Signature - IAcStPlugin2 interface

VB.NET:

Public Function GetError() As AcStError _
              Implements IAcStPlugin2.GetError
    Return ...
End Function

C#:

public AcStError GetError()
{
    return ...;
}
object

Type: IAcStPlugin2 interface

The object this method applies to.

Return Value (RetVal)

Type: AcStError object

The current error that is being checked.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2004 and later

Examples - AcStErrorIterator object

VB.NET:

Not available

C#:

Not available

Examples - IAcStPlugin2 interface

VB.NET:

Public Function GetError() As AcStError Implements IAcStPlugin2.GetError
    Return m_pError
End Function

C#:

public AcStError GetError()
{
    return m_pError;
}