Initialize Method (ActiveX/CSP)

Initializes the plug-in.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

Public Sub Initialize(pMgr) _
              Implements IAcStPlugin2.Initialize
    ...
End Sub

C#:

public void Initialize(pMgr)
{
    ...;
}
object

Type: IAcStPlugin2 interface

The interface this method applies to.

pMgr

Access: Input-only

Type: AcStManager object

The Standards Manager object that manages the plug-in.

Return Value (RetVal)

No return value.

Remarks

Plug-in implementations that need to use methods of the IAcStManager object will want to cache this pointer in a class member variable. Otherwise, you will have to instantiate your own AcStManager object when needed.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Public Sub Initialize(ByVal pStdsMgr As AcStManager) _
           Implements IAcStPlugin2.Initialize

    ' Store the pointer to the manager object
    m_pManager = pStdsMgr
    m_pPlugin = Me
End Sub

C#:

public void Initialize(AcStManager pStdsMgr)
{
    // Store the pointer to the manager object
    m_pManager = pStdsMgr;
    m_pPlugin = this;
}