SetProgressMeter Method (ActiveX/ATO)

Registers a progress handler for the transmittal set.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

VB.NET:

object.setProgressMeter(meter, add)

C#:

object.setProgressMeter(meter, add);
object

Type: TransmittalOperation object

The object this method applies to.

meter

Access: Input-only

Type: TransmittalProgressHandler object

The progress handler to register.

add

Access: Input-only

Type: Long

  • 0 (False): Removes the progress handler from the transmittal set
  • 1 (True): Adds a progress handler to the transmittal set

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2005 and later

Examples

VB.NET:

' Custom command to create a transmittal package from a sheet set
<CommandMethod("eTransmitDSTFile")> _
Public Shared Sub eTransmitDSTFile()

    ' Create a transmittal operation
    Dim tro As TransmittalOperation = New TransmittalOperation()

    ' Setup the transmittal behavior
    Dim ti As TransmittalInfo = _
        TransInfo(tro.getTransmittalInfoInterface(), "C:\Users\Public\TransmittalAPITest\")

    ' Add a file notification handler
    Dim fileHandler As New MyTransFileNotifier
    tro.subscribeToAddFileNotification(fileHandler)

    ' Setup the progress meter for use with sheet selection sets, _
    ' sheet sets, and the creation of a transmittal package
    Dim pmHandler As New MyProgressHandler
    tro.setProgressMeter(pmHandler, 1)

    ' Add a sheet set and the drawings referenced in it
    ' Get a reference to the Sheet Set Manager object
    Dim sheetSetManager As IAcSmSheetSetMgr = New AcSmSheetSetMgr

    ' Open a sheet set (DST) file
    Dim sheetSetDatabase As AcSmDatabase = _
        sheetSetManager.OpenDatabase("C:\AutoCAD\Sample\Sheet Sets\Architectural\IRD Addition.dst", False)

    ' Get the sheet set from the database and process it
    ' 0 - Do not include DST file or support files referenced
    '     by the DST file (templates, blocks, ...)
    ' 1 - Include DST file, all files referenced by the DST file, 
    '     its(sheets And references)
    tro.archiveSheetSet(sheetSetDatabase.GetSheetSet(), vbTrue)

    ' Close the sheet set
    sheetSetManager.Close(sheetSetDatabase)

    ' Remove the file notification handler
    tro.cancelSubscriptionToAddFileNotification(fileHandler)

    ' Remove the progress meter handler
    pmHandler = Nothing

    ' Create the transmittal package
    ' Files are copied and resaved to the path specified by the destinationRoot property
    ' and the other settings of the TransmittalInfo object.
    tro.createTransmittalPackage()
End Sub

C#:

// Custom command to create a transmittal package from a sheet set
[CommandMethod("eTransmitDSTFile")]
public static void eTransmitDSTFile()
{
    // Create a transmittal operation
    TransmittalOperation tro = new TransmittalOperation();

    // Setup the transmittal behavior
    TransmittalInfo ti =
        TransInfo(tro.getTransmittalInfoInterface(), "C:\\Users\\Public\\TransmittalAPITest\\");

    // Add a file notification handler
    MyTransFileNotifier fileHandler = new MyTransFileNotifier();
    tro.subscribeToAddFileNotification(fileHandler);

    // Setup the progress meter for use with sheet selection sets, _
    // sheet sets, and the creation of a transmittal package
    MyProgressHandler pmHandler = new MyProgressHandler();
    tro.setProgressMeter(pmHandler, 1);

    // Add a sheet set and the drawings referenced in it
    // Get a reference to the Sheet Set Manager object
    IAcSmSheetSetMgr sheetSetManager = new AcSmSheetSetMgr();

    // Open a sheet set (DST) file
    AcSmDatabase sheetSetDatabase =
        sheetSetManager.OpenDatabase("C:\\AutoCAD\\Sample\\Sheet Sets\\Architectural\\IRD Addition.dst", false);

    // Get the sheet set from the database and process it
    // 0 - Do not include DST file or support files referenced
    //     by the DST file (templates, blocks, ...)
    // 1 - Include DST file, all files referenced by the DST file, 
    //     its(sheets And references)
    tro.archiveSheetSet(sheetSetDatabase.GetSheetSet(), 1);

    // Close the sheet set
    sheetSetManager.Close(sheetSetDatabase);

    // Remove the file notification handler
    tro.cancelSubscriptionToAddFileNotification(fileHandler);

    // Remove the progress meter handler
    pmHandler = null;

    // Create the transmittal package
    // Files are copied and resaved to the path specified by the destinationRoot property
    // and the other settings of the TransmittalInfo object.
    tro.createTransmittalPackage();
}