OverwriteHandler Method (ActiveX/ATO)

Used to determine whether a file should be overwritten during the creation of a transmittal package.

For internal use only.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

VB.NET:

Friend Class custom_class_name
    Implements TransmittalFileOverwriteHandler

    Public Function overwriteHandler(pFile As TransmittalFile, bstrDest As String) As OverwriteResponseType _
        Implements ITransmittalFileOverwriteHandler.overwriteHandler
        ...
    End Function

End Class

C#:

internal class custom_class_name : TransmittalFileOverwriteHandler
{
    public OverwriteResponseType overwriteHandler(TransmittalFile pFile, string bstrDest)
    {
        ...
        return RetVal;
    }
}
custom_class_name

The name of the custom class.

pFile

Access: Input-only

Type: TransmittalFile object

The file in the files graph of the transmittal set for which you want to obtain the default overwrite response.

bstrDest

Access: Input-only

Type: String

The destination path for the file after the creation of the transmittal package.

Return Value (RetVal)

Type: OverwriteResponseType enum

Remarks

This method is for internal use only.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Not available

C#:

Not available