SetDbStandardsArray Method (ActiveX/CSP)

Stores the list of standard files to use to check a database.

For internal use only.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

object.SetDbStandardsArray(pDb, stdNameArray)

C#:

object.SetDbStandardsArray(pDb, stdNameArray);
object

Type: AcStManager object

The object this method applies to.

pDb

Access: Input-only

Type: AcadDatabase object

The database object of the drawing file to check.

stdNameArray

Access: Input-only

Type: Variant (Array of Strings)

The array of names for each standards drawing (DWS) files to use when checking the database.

Return Value (RetVal)

No return value.

Remarks

This method performs no validation of the DWS file names and paths passed. It replaces existing references in the database with those passed to the method. If the input array is null, any existing references are removed from the database.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Not available

C#:

Not available