Done Method (ActiveX/CSP)

Triggered after the Next method is executed.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature - AcStErrorIterator object

For internal use only.

VB.NET:

RetVal = object.Done()

C#:

RetVal = object.Done();
object

Type: AcStErrorIterator object

The object this method applies to.

Signature - IAcStPlugin2 interface

VB.NET:

Public Function Done() As Boolean _
                Implements IAcStPlugin2.Done 
    Return ...
End Function

C#:

public bool Done()
{
    return ...;
}
object

Type: IAcStPlugin2 interface

The interface this method applies to.

Return Value (RetVal)

Type: Boolean

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2004 and later

Examples - AcStErrorIterator object

VB.NET:

Not available

C#:

Not available

Examples - IAcStPlugin2 interface

VB.NET:

Public Function PlugIn_Done() As Boolean Implements IAcStPlugin2.Done
    Return IsNothing(m_pError)
End Function

C#:

public bool PlugIn_Done()
{
    return (m_pError == null);
}

bool IAcStPlugin2.Done()
{
    return PlugIn_Done();
}