UpdateStatus Method (ActiveX/CSP)

Updates the result status of the specified error.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature - AcStError object

VB.NET:

object.UpdateStatus()

C#:

object.UpdateStatus();
object

Type: AcStError object

The object this method applies to.

Signature - IAcStPlugin2 interface

VB.NET:

Public Sub UpdateStatus(pError) _
                    Implements AcStMgr.IAcStPlugin2.UpdateStatus
    ...
End Sub

C#:

public void UpdateStatus(pError)
{
    ...;
}
object

Type: IAcStPlugin2 interface

The object this method applies to.

pError

Access: Input-only

Type: AcStError object

The error object's whose result status to update.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2004 and later

Examples - AcStError object

VB.NET:

Not available

C#:

Not available

Examples - IAcStPlugin2 interface

VB.NET:

Public Sub UpdateStatus(ByVal pError As AcStError) _
                        Implements IAcStPlugin2.UpdateStatus

End Sub

C#:

public void UpdateStatus(AcStError pError)
{

}