Reports whether the error is ignored by a user and the name of the user.
Supported platforms: Windows only
Namespace: AcStMgr
Assembly: AcStMgr.tlb
VB.NET:
object.IgnoredByUserGet(bIgnored, UserName)
C#:
object.IgnoredByUserGet(ref bIgnored, ref UserName);
Type: AcStError object
The object this method applies to.
Access: Input/Output
Type: Boolean
Access: Input/Output
Type: String
The name of the user who ignored the error.
No return value.
No additional remarks.
Releases: AutoCAD 2004 and later
VB.NET:
Public Function GetError() As AcStError Implements IAcStPlugin2.GetError ' Gets the ignore status of an error and outputs the information to the Output window Dim bFlag As Boolean = False Dim sName As String = "" m_pError.IgnoredByApplicationGet(bFlag, sName) Debug.Print(vbLf + "Ignored status: " + bFlag.ToString() + " App Name: " + sName) m_pError.IgnoredByUserGet(bFlag, sName) Debug.Print(vbLf + "Ignored status: " + bFlag.ToString() + " User Name: " + sName) Return m_pError End Function
C#:
public AcStError GetError() { // Gets the ignore status of an error and outputs the information to the Output window bool bFlag = false; string sName = ""; m_pError.IgnoredByApplicationGet(bFlag, sName); Debug.Print("\nIgnored status: " + bFlag.ToString() + " App Name: " + sName); m_pError.IgnoredByUserGet(bFlag, sName); Debug.Print("\nIgnored status: " + bFlag.ToString() + " User Name: " + sName); return m_pError; }