Reports whether the error is ignored by an application and the name of that application.
Supported platforms: Windows only
Namespace: AcStMgr
Assembly: AcStMgr.tlb
VB.NET:
object.IgnoredByApplicationGet(bIgnored, appName)
C#:
object.IgnoredByApplicationGet(ref bIgnored, ref appName);
Type: AcStError object
The object this method applies to.
Access: Input/Output
Type: Boolean
Access: Input/Output
Type: String
The name of the application that ignored the error.
No return value.
No additional remarks.
Releases: AutoCAD 2004 and later
VB.NET:
Public Function GetError() As AcStError Implements IAcStPlugin2.GetError ' Gets the ignore status of an error and outputs the information to the Output window Dim bFlag As Boolean = False Dim sName As String = "" m_pError.IgnoredByApplicationGet(bFlag, sName) Debug.Print(vbLf + "Ignored status: " + bFlag.ToString() + " App Name: " + sName) m_pError.IgnoredByUserGet(bFlag, sName) Debug.Print(vbLf + "Ignored status: " + bFlag.ToString() + " User Name: " + sName) Return m_pError End Function
C#:
public AcStError GetError() { // Gets the ignore status of an error and outputs the information to the Output window bool bFlag = false; string sName = ""; m_pError.IgnoredByApplicationGet(bFlag, sName); Debug.Print("\nIgnored status: " + bFlag.ToString() + " App Name: " + sName); m_pError.IgnoredByUserGet(bFlag, sName); Debug.Print("\nIgnored status: " + bFlag.ToString() + " User Name: " + sName); return m_pError; }