Populates the provided array with class names of objects to be checked.
Supported platforms: Windows only
Namespace: AcStMgr
Assembly: AcStMgr.tlb
VB.NET:
Public Function GetObjectFilter() As Object _ Implements IAcStPlugin2.GetObjectFilter Return ... End Function
C#:
public object GetError() { return ...; }
Type: IAcStPlugin2 interface
The object this method applies to.
Type: Variant (Array of Object object)
An array containing the type of objects (class names) that it can check.
It is recommended to specify only one type of object for each plug-in.
Plug-ins use this to tell the Standards framework which object types to check. The object types must derive from AcRxClass, AcDbObject, or AcadObject. The Standards framework needs this information to filter out objects that are not relevant to a plug-in.
Releases: AutoCAD 2004 and later
VB.NET:
Public Function GetObjectFilter() As Object _ Implements IAcStPlugin2.GetObjectFilter ' Array of object types to check Dim sFilterArray(0) As String ' << Change based on standards implementation >> sFilterArray(0) = "AcDbLayerTableRecord" Return sFilterArray End Function
C#:
public object GetObjectFilter() { // Array of object types to check string[] sFilterArray = new string[1]; // << Change based on standards implementation >> sFilterArray[0] = "AcDbLayerTableRecord"; return sFilterArray; }