vlr-reaction-set (AutoLISP/ActiveX)

Adds or replaces a callback function in a reactor

Supported Platforms: Windows only

Signature

(vlr-reaction-set reactor event function)
reactor

Type: VLR object

An object.

event

Type: Symbol

A symbol denoting one of the event types available for this reactor type.

function

Type: Symbol

A symbol representing the AutoLISP function to be added or replaced.

Return Values

Type: Symbol

The value of the function argument.

Examples

The following command changes the circleReactor reactor to call the print-area function when an object is modified:

(vlr-reaction-set circleReactor :vlr-modified 'print-area)
PRINT-AREA