Reactor Functions Reference (AutoLISP/ActiveX)

Note: ActiveX support in AutoLISP is limited to Windows only.

Reactor functions define, query, and delete reactors and reactor properties. Before you can use these functions, you must load AutoLISP reactor support by issuing the following function:

(vl-load-com)

The vl-load-com function initializes reactor support and a number of other AutoLISP extensions.

Reactor functions

Function

Description

(vl-load-com)

Loads AutoLISP reactor support functions and other AutoLISP extensions

(vlr-acdb-reactor data callbacks)

Constructs a database (global) reactor object

(vlr-add obj)

Enables a disabled reactor object

(vlr-added-p obj)

Tests to determine whether a reactor object is enabled

(vlr-beep-reaction [args])

Produces a beep sound

(vlr-command-reactor data callbacks)

Constructs an editor reactor that notifies of a command event

(vlr-current-reaction-name)

Returns the name (symbol) of the current event, if called from within a reactor's callback

(vlr-data obj)

Returns application-specific data associated with a reactor

(vlr-data-set obj data)

Overwrites application-specific data associated with a reactor

(vlr-deepclone-reactor obj data)

Constructs an editor reactor object that provides notification of deep clone events

(vlr-docmanager-reactor obj data)

Constructs a reactor object that provides notification of MDI-related events

(vlr-dwg-reactor obj data)

Constructs an editor reactor object that provides notification of a drawing event (for example, opening or closing a drawing file)

(vlr-dxf-reactor obj data)

Constructs an editor reactor object that notifies of an event related to reading or writing of a DXF file

(vlr-editor-reactor data callbacks)

Constructs an editor (global) reactor object

(vlr-insert-reactor data callbacks)

Constructs an editor reactor object that notifies of an event related to block insertion

(vlr-linker-reactor data callbacks)

Constructs a linker (global) reactor object

(vlr-lisp-reactor data callbacks)

Constructs an editor reactor object that notifies of a LISP event

(vlr-miscellaneous-reactor data callbacks)

Constructs an editor reactor object that does not fall under any of the other editor reactor types

(vlr-mouse-reactor data callbacks)

Constructs an editor reactor object that provides notification of a mouse event (for example, a double-click)

(vlr-notification reactor)

Determines whether or not a reactor's callback function will execute if its associated namespace is not active

(vlr-object-reactor owners data callbacks)

Constructs an object reactor object

(vlr-owner-add reactor owner)

Adds an object to the list of owners of an object reactor

(vlr-owner-remove reactor owner)

Removes an object from the list of owners of an object reactor

(vlr-owners reactor)

Returns the list of owners of an object reactor

(vlr-pers reactor)

Makes a reactor persistent

(vlr-pers-list [reactor])

Returns a list of persistent reactors in the current drawing

(vlr-pers-p reactor)

Determines whether or not a reactor is persistent

(vlr-pers-release reactor)

Makes a reactor transient

(vlr-reaction-name reactor-type)

Returns a list of all callback conditions for this reactor type

(vlr-reaction-set reactor event function)

Adds or replaces a callback function in a reactor

(vlr-reactions reactor)

Returns a list of pairs ( event-name . callback_function) for the reactor

(vlr-reactors [reactor-type ...])

Returns a list of reactors of the specified types

(vlr-remove reactor)

Disables a reactor

(vlr-remove-all reactor-type)

Disables all reactors of the specified type

(vlr-set-notification reactor 'range)

Defines whether or not a reactor's callback function will execute if its associated namespace is not active

(vlr-sysvar-reactor data callbacks)

Constructs an editor reactor object that provides notification of a change to a system variable

(vlr-toolbar-reactor data callbacks)

Constructs an editor reactor object that provides notification of a change to the bitmaps in a toolbar

(vlr-trace-reaction)

A pre-defined callback function that prints one or more callback arguments in the Trace window

(vlr-type reactor)

Returns a symbol representing the reactor type

(vlr-types)

Returns a list of all reactor types

(vlr-undo-reactor data callbacks)

Constructs an editor reactor object that provides notification of an undo event

(vlr-wblock-reactor data callbacks)

Constructs an editor reactor object that provides notification of an event related to writing a block

(vlr-window-reactor data callbacks)

Constructs an editor reactor object that notifies of an event related to moving or sizing an AutoCAD window

(vlr-xref-reactor data callbacks)

Constructs an editor reactor object that provides notification of an event related to attaching or modifying XREF