Data Conversion Functions Reference (AutoLISP/ActiveX)

Note: ActiveX support in AutoLISP is limited to Windows only.

The following table provides summary descriptions of the AutoLISP ActiveX data conversion functions.

Data conversion functions

Function

Description

(vlax-3D-point list)

Creates an ActiveX-compatible 3D point structure

(vlax-ename->vla-object entname)

Transforms entity to VLA-object

(vlax-make-safearray type '(l-bound . u-bound) ['( l-bound . u-bound) ...])

Creates a safearray

(vlax-make-variant value type)

Creates a variant data type

(vlax-safearray-fill var 'element-values)

Stores elements in a safearray

(vlax-safearray-get-dim var)

Returns the number of dimensions in a safearray object

(vlax-safearray-get-element var element)

Returns an element from an array

(vlax-safearray-get-l-bound var dim)

Returns the lower boundary (starting index) of a dimension of an array

(vlax-safearray-get-u-bound var dim)

Returns the upper boundary (end index) of a dimension of an array

(vlax-safearray-put-element var element value)

Adds or updates an element in an array

(vlax-safearray-type var)

Returns the data type of a safearray

(vlax-safearray->list var)

Returns the elements of a safearray in list form

(vlax-tmatrix list)

Returns a suitable representation for a 4 x 4 transformation matrix to be used in VLA methods

(vlax-variant-change-type var type)

Returns the value of a variant after changing it from one data type to another

(vlax-variant-type var)

Returns the data type of a variant

(vlax-variant-value var)

Returns the value of a variant

(vlax-vla-object->ename obj)

Transforms a VLA-object to an AutoLISP entity