vlax-safearray-get-u-bound (AutoLISP/ActiveX)

Returns the upper boundary (end index) of a dimension of an array

Supported Platforms: Windows only

Signature

(vlax-safearray-get-u-bound var dim)
var

Type: Safearray

A variable containing a safearray.

dim

Type: Integer

A dimension of the array. The first dimension is dimension 1.

Return Values

Type: Integer

A numeric value representing the upper boundary (end index) of the dimension. If var is not an array, or dim is invalid (for example, 0, or a number greater than the number of dimensions in the array), an error results.

Examples

The following examples evaluate a safearray defined as follows:

(vlax-make-safearray vlax-vbString '(1 . 2) '(0 . 1) ))

Get the end index value of the array's first dimension:

(vlax-safearray-get-u-bound tmatrix 1)
2

The first dimension ends with index 2.

Get the end index value of the second dimension of the array:

(vlax-safearray-get-u-bound tmatrix 2)
1

The second dimension starts with index 1.