getcorner (AutoLISP)

Pauses for user input of a rectangle's second corner

Supported Platforms: Windows and Mac OS

Signature

(getcorner pt [msg])
pt

Type: List

A point to be used as the base point.

msg

Type: String

Message to be displayed to prompt the user.

Return Values

Type: List or nil

The getcorner function returns a point in the current UCS, similar to getpoint. If the user supplies a 3D point, its Z coordinate is ignored. The current elevation is used as the Z coordinate.

Remarks

The getcorner function takes a base point argument, based on the current UCS, and draws a rectangle from that point as the user moves the crosshairs on the screen.

The user cannot enter another AutoLISP expression in response to a getcorner request.

Examples

(getcorner '(7.64935 6.02964 0.0))
(17.2066 1.47628 0.0)

(getcorner '(7.64935 6.02964 0.0) "\nPick a corner")
Pick a corner(15.9584 2.40119 0.0)