The following table provides summary descriptions of the AutoLISP user input functions.
User input functions |
|
---|---|
Function |
Description |
(entsel [msg]) |
Prompts the user to select a single object (entity) by specifying a point |
(getangle [pt] [msg]) |
Pauses for user input of an angle, and returns that angle in radians |
(getcorner pt [msg]) |
Pauses for user input of a rectangle's second corner |
(getdist [pt] [msg]) |
Pauses for user input of a distance |
(getfiled title default ext flags) |
Prompts the user for a file name with the standard AutoCAD file dialog box, and returns that file name |
(getint [msg]) |
Pauses for user input of an integer, and returns that integer |
(getkword [msg]) |
Pauses for user input of a keyword, and returns that keyword |
(getorient [pt] [msg]) |
Pauses for user input of an angle, and returns that angle in radians |
(getpoint [pt] [msg]) |
Pauses for user input of a point, and returns that point |
(getreal [msg]) |
Pauses for user input of a real number, and returns that real number |
(getstring [cr] [msg]) |
Pauses for user input of a string, and returns that string |
(initget [bits] [string]) |
Establishes keywords for use by the next user input function call |
(nentsel [msg]) |
Prompts the user to select an object (entity) by specifying a point, and provides access to the definition data contained within a complex object |
(nentselp [msg] [pt]) |
Provides similar functionality to that of the nentsel function without the need for user input |