arxunload (AutoLISP)

Unloads an ObjectARX application

Supported Platforms: Windows and Mac OS

Signature

(arxunload application [onfailure])
application

Type: String

A quoted string or a variable that contains the name of a file that was loaded with the arxload function. You can omit the extension from the file name; .arx (Windows) or .bundle (Mac OS).

onfailure

Type: String

An expression to be executed if the unload fails.

Return Values

Type: String

The application name, if successful. If unsuccessful and the onfailure argument is supplied, arxunload returns the value of this argument; otherwise, failure results in an error message.

Note that locked ObjectARX applications cannot be unloaded. ObjectARX applications are locked by default.

Examples

Unload the Autoloader application that was loaded in the arxload function example:

(arxunload "autoloader")
"autoloader"