tblsearch (AutoLISP)

Searches a symbol table for a symbol name

Supported Platforms: Windows and Mac OS

Signature

(tblsearch table-name symbol [setnext])
table-name

Type: String

Symbol table to be searched. This argument is not case-sensitive.

symbol

Type: String

Symbol name to be searched for. This argument is not case-sensitive.

setnext

Type: T or nil

If this argument is supplied and is not nil, the tblnext entry counter is adjusted so the following tblnext call returns the entry after the one returned by this tblsearch call. Otherwise, tblsearch has no effect on the order of entries retrieved by tblnext.

Return Values

Type: List (dotted pairs) or nil

If tblsearch finds an entry for the given symbol name, it returns that entry. If no entry is found, tblsearch returns nil.

Examples

The following command searches for a text style named “standard”:

(tblsearch "style" "standard")
((0 . "STYLE") (2 . "STANDARD") (70 . 0) (40 . 0.0) (41 . 1.0) (50 . 0.0) (71 . 0) (42 . 0.3) (3 . "txt") (4 . ""))