Symbol Table and Dictionary-Handling Functions Reference (AutoLISP)

The following table provides summary descriptions of the AutoLISP symbol table and dictionary-handling functions.

Symbol table and dictionary-handling functions

Function

Description

(dictadd ename symbol newobj)

Adds a non-graphical object to the specified dictionary

(dictnext ename symbol [rewind])

Finds the next item in a dictionary

(dictremove ename symbol)

Removes an entry from the specified dictionary

(dictrename ename oldsym newsym)

Renames a dictionary entry

(dictsearch ename symbol [setnext])

Searches a dictionary for an item

(layoutlist)

Returns a list of all paper space layouts in the current drawing

(namedobjdict)

Returns the entity name of the current drawing's named object dictionary, which is the root of all non-graphical objects in the drawing

(setview view_description [vport_id])

Establishes a view for a specified viewport

(snvalid sym_name)

Checks the symbol table name for valid characters

(tblnext table-name [rewind])

Finds the next item in a symbol table

(tblobjname table-name symbol)

Returns the entity name of a specified symbol table entry

(tblsearch table-name symbol [setnext])

Searches a symbol table for a symbol name

(vlax-ldata-delete dict key)

Erases AutoLISP data from a drawing dictionary

Note: Extended AutoLISP extension: requires vl-load-com

(vlax-ldata-get dict key [default-data])

Retrieves AutoLISP data from a drawing dictionary

Note: Extended AutoLISP extension: requires vl-load-com

(vlax-ldata-list dict)

Lists AutoLISP data in a drawing dictionary

Note: Extended AutoLISP extension: requires vl-load-com

(vlax-ldata-put dict key data)

Stores AutoLISP data in a drawing dictionary

Note: Extended AutoLISP extension: requires vl-load-com

(vlax-ldata-test data)

Determines whether data can be saved over a session boundary

Note: Extended AutoLISP extension: requires vl-load-com