null (AutoLISP)

Verifies that an item is bound to nil

Supported Platforms: Windows and Mac OS

Signature

(null item)
item

Type: Integer, Real, String, List, Ename (entity name), T, or nil

An AutoLISP expression.

Return Values

Type: T or nil

T if item evaluates to nil; otherwise nil.

Examples

(setq a 123 b "string" c nil)
nil

(null a)
nil

(null b)
nil

(null c)
T

(null '())
T