not (AutoLISP)

Verifies that an item evaluates to nil

Supported Platforms: Windows and Mac OS

Signature

(not item)
item

Type: Integer, Real, String, List, Subroutine, Ename (entity name), T, or nil

An AutoLISP expression.

Return Values

Type: T or nil

T if item evaluates to nil; otherwise nil.

Remarks

Typically, the null function is used for lists, and not is used for other data types along with some types of control functions.

Examples

(setq a 123 b "string" c nil)
nil

(not a)
nil

(not b)
nil

(not c)
T

(not '())
T