vlr-lisp-reactor (AutoLISP/ActiveX)

Constructs an editor reactor object that notifies of a LISP event

Supported Platforms: Windows only

Signature

(vlr-lisp-reactor data callbacks)
data

Type: Integer, Real, String, List, VLA-object, Safearray, Variant, T, or nil

Any AutoLISP data to be associated with the reactor object; otherwise nil if no data.

callbacks

Type: List

A list of pairs of the following form:

(event-name . callback_function)

  • event-name is one of the following Lisp reactor events:

    Lisp reactor events

    Event name

    Description

    :vlr-lispWillStart

    An AutoLISP expression is to be evaluated.

    :vlr-lispEnded

    Evaluation of an AutoLISP expression has been completed.

    :vlr-lispCancelled

    Evaluation of an AutoLISP expression has been canceled.

  • callback_function is a symbol representing a function to be called when the event fires. Each callback function accepts two arguments:

    reactor_object -- The VLR object that called the callback function.

    list -- A list of extra data elements associated with the particular event. The contents of this list for particular events are shown in the table Lisp reactor callback data” table.

    Lisp reactor callback data

    Name

    List length

    Parameters

    :vlr-lispEnded

    :vlr-lispCancelled

    0

    :vlr-lispWillStart

    1

    A string containing the first line of the AutoLISP expression to evaluate.

Return Values

Type: VLR object

The reactor_object argument from the callback_function.

Examples

N/A