= (equal to) (AutoLISP)

Compares arguments for numerical equality

Supported Platforms: Windows and Mac OS

Signature

(= numstr [numstr ...])
numstr

Type: Integer, Real, or String

A number or string.

Return Values

Type: T or nil

T, if all arguments are numerically equal; otherwise nil. If only one argument is supplied, T is returned.

Examples

(= 4 4.0)
T

(= 20 388)
nil

(= 2.4 2.4 2.4)
T

(= 499 499 500)
nil

(= "me" "me")
T

(= "me" "you")
nil