/= (not Equal to) (AutoLISP)

Compares arguments for numerical inequality

Supported Platforms: Windows and Mac OS

Signature

(/= numstr [numstr ...])
numstr

Type: Integer, Real, or String

A number or string.

Return Values

Type: T or nil

T, if no two successive arguments are the same in value; otherwise nil. If only one argument is supplied, T is returned.

Note: The behavior of /= does not quite conform to other LISP dialects. The standard behavior is to return T if no two arguments in the list have the same value. In AutoLISP, /= returns T if no successive arguments have the same value; see the examples that follow.

Examples

(/= 10 20)
T

(/= "you" "you")
nil

(/= 5.43 5.44)
T

(/= 10 20 10 20 20)
nil

(/= 10 20 10 20)
T
Note: In the last example, although there are two arguments in the list with the same value, they do not follow one another; thus/= evaluates to T.